Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rename Alc to alc | Chris Robinson | 2019-07-28 | 1 | -80/+0 |
| | |||||
* | Rename alMain.h to alcmain.h | Chris Robinson | 2019-07-28 | 1 | -1/+1 |
| | | | | And move it and alu.h to Alc/. | ||||
* | Remove the UNUSED macro | Chris Robinson | 2019-07-28 | 1 | -2/+2 |
| | |||||
* | Don't bother with an explicit Loopback backend type | Chris Robinson | 2018-12-29 | 1 | -8/+4 |
| | |||||
* | Return a unique_ptr for the backend | Chris Robinson | 2018-12-29 | 1 | -2/+2 |
| | |||||
* | Make the backend type an enum class | Chris Robinson | 2018-12-29 | 1 | -4/+4 |
| | |||||
* | Convert the backends to use proper inheritence | Chris Robinson | 2018-12-28 | 1 | -47/+18 |
| | |||||
* | Get rid of the unnecessary STATIC_(UP)CAST macros | Chris Robinson | 2018-12-27 | 1 | -4/+3 |
| | |||||
* | Use a proper constructor/destructor for the ALCbackend base | Chris Robinson | 2018-12-27 | 1 | -3/+2 |
| | |||||
* | Remove extraneous typedef, struct, and enum keywords | Chris Robinson | 2018-12-24 | 1 | -1/+1 |
| | |||||
* | Use a std::string for the device name | Chris Robinson | 2018-11-18 | 1 | -2/+1 |
| | |||||
* | Simplify a couple checks | Chris Robinson | 2018-11-15 | 1 | -10/+3 |
| | |||||
* | Update the loopback backend | Chris Robinson | 2018-11-15 | 1 | -46/+33 |
| | |||||
* | Use a regular char* for the device's name | Chris Robinson | 2018-11-15 | 1 | -1/+2 |
| | |||||
* | Use std::string instead of al_string for enumerating | Chris Robinson | 2018-11-15 | 1 | -2/+2 |
| | |||||
* | Convert the loopback backend to C++ | Chris Robinson | 2018-11-09 | 1 | -0/+135 |